RContour.clockwise



  • Hi!
    I found a bug when I run sometimes RContour.clockwise - this is the code:

    Traceback (most recent call last):
      File "__init__.py", line 165, in <module>
      File "__init__.py", line 155, in leg
      File "/Applications/RoboFont_3.0.app/Contents/Resources/lib/python3.6/fontParts/base/base.py", line 609, in __get__
      File "/Applications/RoboFont_3.0.app/Contents/Resources/lib/python3.6/fontParts/base/contour.py", line 274, in _get_base_clockwise
      File "/Applications/RoboFont_3.0.app/Contents/Resources/lib/python3.6/fontParts/base/normalizers.py", line 615, in normalizeBoolean
    fontParts.base.errors.FontPartsError: Boolean values must be True or False, not 'True'.
    

    RoboFont version:
    Version 3.0 (built 1803062007)
    Python3.6 embedded
    AFDKO version 2.5.65590
    GlyphNameFormatter version 0.28 - git commit: 400



  • I temporarily fixed the issue by modifying straightly the normalizers.py file in /Applications/RoboFont_3.0.app/Contents/Resources/lib/python3.6/fontParts/base/normalizers.py in this way:

    0_1524066566913_Schermata 2018-04-18 alle 17.47.41.png

    but I think it should get a proper fix soon.

    Have a good day 🙂


  • admin

    this is a known issue and already being fixed in one of the embedded packages:

    see https://github.com/typesupply/defcon/commit/bce898c1c2e6b24c4774fe9ca6f7a9f5b80ed6a0

    this only happens with open contours...
    an update is scheduled soon


Log in to reply
 

Looks like your connection to RoboFont ● Forum was lost, please wait while we try to reconnect.