Bug on deleting contours

  • Deleting a contour, and trying to click the remaining outlines yielded this:

    Traceback (most recent call last):
      File "lib/eventTools/editingTool.pyc", line 195, in _mouseDown
      File "lib/eventTools/editingTool.pyc", line 301, in mouseDownSingeClick
      File "lib/fontObjects/doodleSelection.pyc", line 373, in addSegment
      File "lib/fontObjects/doodleContour.pyc", line 55, in _get_segments

  • great! thanks

  • admin

    thanks for reporting
    this should be solved in the next version

  • It seems to happen even on shapes that haven't been copied/pasted.

    Trying to narrow down the problem, it seems to happen when more than one points are selected. Specifically when one of them is the starting point. I've uploaded an example here: http://tktype.com/deletepointbug.png

    When the selected points on the left are deleted, the problem arises. On the right, with the outer contour's starting point moved, I can delete them with no problem.

  • admin

    Do you remember you copied the contour in RoboFont first? There was a bug in copy paste (you see the starting point jumping) during copying contours. This should be solved in the next version (1.2)

  • I too get this error once in a while. Sometimes restarting RoboFont resolves the issue, but not always. The original outlines were exported from FontLab using the robofab script, if that helps?

Log in to reply