UNSOLVED makeOTF and non-ascii characters

  • Hi, I'm back with maybe another stupid question. So from what I understand the ufo2fdk will convert non-ascii characters to the correct unicode/macRoman values in the fontmenunamedb. But when attempting to testInstall(), the file won't generate. I ran the same file through the command line with makeotf -f font.ufo -o font.otf and it generates totally fine. I also ran a test through my FDK mastering workflow with the appropriate mac/windows lines, which worked. Is this a limitation of roboFont or am I just blind to my mistake?
    The only name tables that can't have non-ascii characters are the postscript tables, correct?

  • @connor I think i recall @benkiel had some relevant mastering experience with Vēlo...

    Any tips, Ben?

  • Unfortunately, the release mode doesn't help. I also tried setting the testInstall settings to TTF since that's always in release mode..but nothing:( There is also no AFDKO output, only python traceback:

    /Applications/RoboFont.app/Contents/Resources/lib/python36.zip/lib/doodleFontWindow.py:332: ResourceWarning: unclosed file <_io.BufferedWriter name='/var/folders/1p/78hmxxfx6h12qlgv9j2r10_00000gn/T/tmpzxq0ugvb/font.otf'>
    Traceback (most recent call last):
      File "lib/doodleFontWindow.pyc", line 328, in _compileFont
      File "lib/fontObjects/doodleLayer.pyc", line 295, in generate
      File "/Applications/RoboFont.app/Contents/Resources/lib/python3.6/fontCompiler/compiler.py", line 148, in generateFont
      File "/Applications/RoboFont.app/Contents/Resources/lib/python3.6/fontCompiler/baseCompiler.py", line 331, in compile
      File "/Applications/RoboFont.app/Contents/Resources/lib/python3.6/fontCompiler/baseCompiler.py", line 390, in _makeFDKParts
    UnicodeEncodeError: 'ascii' codec can't encode character '\xe9' in position 1: ordinal not in range(128)

    For the time being I am just removing the 'é' from the font names. I am going to try and investigate the root of the problem this weekend. Thanks, Colin.

  • Try running in "release" mode. Is there any AFDKO output in the output window? (Looking for [Error] and [Fatal] here)