Crash on save as and generate font

  • Hi –

    I'm working on a pretty large font file (almost 11k glyphs and about 2.5k lines of features, mostly classes and calt substitutions) and Robofont crashes whenever I try to either "Saves As..." or "Generate Font".

    I can generate font files without issue using the same .ufo via makeotf on the command line and Glyphs (though makeotf is much faster).

    Any idea what is going on here? Is this just a result of the file being huge or could there be something in the file specific to Robofont that is causing problems?

    I'm on version 1.8.4


    – Mike Gallagher

  • admin

    Hi Mike

    not sure what is going on, it should work. It will not be the fastest option 🙂

    All tracebacks are also saved into a log file. You will find the log file in <userName>/Library/Application Support/RoboFont/roboFont.log.

    Can you send me either the log file or ufo for testing? (this can also be off list)


  • Hi Frederik –

    Interesting. I checked the log but there doesn't seem to be anything notable re: this issue.

    I'll send you the log and ufo separately.

    – Mike

  • So after running ufonormalizer on the files things seem to work. It takes a really long time to compile (about 10 minutes, though that drops to about 1 or 2 minutes if I turn off autohinting), but it does work. I'm not sure what ufonormalizer actually changed (it looks the same to me) but nothing crashes and there is a working OTF at the end of the process.

Log in to reply

Looks like your connection to RoboFont ● Forum was lost, please wait while we try to reconnect.