SOLVED glyphs change when generating a ttf

  • Hi there,
    I have drawn a few letters which I would like to interpolate. When I generate OTFs, all works fine. If I generate a TTF (Variable Font), the glyphs don't have the right allocation any more. When I upload it to a website (eg. Axis Praxis or Font Gauntlet), they seem to have switched. However, if I use Skateboard, they seem to be correct and I can type normal.

    This are both generated OTFs used in InDesign:Screen Shot 2022-01-07 at 20.52.41.png

    And this is how the word Pia looks when the TTF is uploaded to a website:
    Screen Shot 2022-01-07 at 20.53.01.png

    To generate the TTF, I created a designspace and then used Batch generate. Usually that worked fine, but this time not.
    Anybody knows what could be the problem?

    Thanks for your help in advance,

  • great, good to know! 🎉

  • I was using RoboFont 3.4
    Skateboard (when opening with Sublime Text) it says Build 4121 from October 26, 2021
    How to find out the version of Batch, I have no idea.

    I just upgraded my RF licence to 4.1 and it is working fine now. Problem solved :)

    Thank you for your help!

  • admin

    in some older version of RoboFont there was an issue when the glyph space was not set.

    hope this helps!

  • Hi @Manufraktur!

    Can you list the versions of the tools you are using?

    • RoboFont
    • Skateboard
    • Batch


Log in to reply