Strange indentation behavior in RF 4.1



  • When I write scripts in the script window, I often get strange indentation behavior. Sometimes, it will appear that the cursor is still at the first column when it should auto-indent by one tab, but then once I start typing, it actually jumps two tabs forward:

    Kapture 2022-01-29 at 18.23.18.gif

    I have to then use the Indent and Decent buttons/shortcuts to fix the indentation before it will run properly.

    I don’t quite understand the patter of it, but I think it almost always (maybe always always?) happens on the second level of indentation, and maybe more than that.

    This older post seems at least partially related: https://forum.robofont.com/topic/757/rf-drawbot-misleading-cursor-position-in-scripting-window/13?_=1643495424224

    My main font in here was Recursive (I forget which exact version, now that I’ve been changing it to test others), and I haven’t seen or heard of similar behavior anywhere else. I later tested it with one of the "Code" versions of Recursive, which is set to have only a single width in glyphs, unlike the main versions of it. This worked for indents, but had a misplaced cursor.

    I also quickly tested this with MD IO 0.2 and IBM Plex Mono, and both suffered from issue of a misplaced cursor, though not from double indents. I then tried Hack, and that seemingly had no issues.

    Not quite sure what might be causing this, but it’s pretty rough! I suppose I’ll change to scripting in RF with Hack, for the time being.

    • RoboFont Version 4.1 (build 2111241049)
      • Also happened in the 4.1 Beta, and maybe also 4
    • macOS Catalina 10.15.7


  • 👋

    sorry for letting so many days pass by before answering the post

    @frederik and I have received multiple reports concerning this issue, but we could not reproduce it on our machines.

    We are both running Monterey, so this might mean two things:

    • Apple fixed some underlying object meanwhile
    • it is a font related issue and we are not testing with the same fonts

    Could you send me via email the files you are using for testing so I can see if I manage to reproduce it?

    Thanks!



  • Makes sense that this could be an OS thing.

    Sure! I don’t actually have to send an email, as several of the fonts are public:



  • I know it's not nice to say but "it works fine on my machine" 😅

    Screenshot 2022-02-16 at 10.33.34.png

    I assume it is an OS bug


Log in to reply