test install fails to generate font



  • Hello,
    I'm having trouble test installing a font.

    I generated a UFO out of a glyphs source (tried the UFO export in GlyphsApp and converting with glyphsLib)

    Both times I fail to test install with the following error:

    Failed to generate the font for test install
    Traceback (most recent call last):
      File "lib/doodleDelegate.pyc", line 200, in testInstallFont_forWindow_showProgress_option_
      File "lib/fontObjects/doodleFont.pyc", line 300, in generate
      File "lib/fontObjects/doodleLayer.pyc", line 384, in generate
      File "/Applications/RoboFont.app/Contents/Resources/lib/python3.7/fontCompiler/compiler.py", line 147, in generateFont
      File "/Applications/RoboFont.app/Contents/Resources/lib/python3.7/fontCompiler/baseCompiler.py", line 379, in compile
    UnicodeEncodeError: 'ascii' codec can't encode character '\xe4' in position 16: ordinal not in range(128)
    
    --------------------
    Installing This Font Bold failed
    The file does not exist at the specified URL.
    --------------------
    
    

    The files are a bit messy (I'm only doing the mastering and production) so I can't really say what was going on with the files before.

    I solved the problem by copying everything (Contours, Components, Anchors, Metrics, Groups, Kerning and Features) to a new UFO, but I’m still curious what the reason of this error was.



  • Update:

    It only solved the problem until I also filled in the font infos.

    UnicodeEncodeError: 'ascii' codec can't encode character '\xe4' in position 16: ordinal not in range(128)
    

    The font name had an /ä in it which it did not like.
    So I'll have to work with a localised name table I guess.


  • admin

    Should be fixed here https://github.com/robotools/ufo2fdk/commit/99a01d340de3ef3c3d86708c45afebd682daab00

    and present in the upcoming beta

    thanks!


Log in to reply