SOLVED Installing Test Font Error

  • When trying to generate a test install I continue to get the following error

    "Failed to generate the font for test install
    Traceback (most recent call last):
    File "/Applications/", line 100, in compile
    struct.error: argument out of range

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "lib/doodleDelegate.pyc", line 188, in testInstallFont_forWindow_showProgress_option_
    File "lib/fontObjects/doodleFont.pyc", line 300, in generate
    File "lib/fontObjects/doodleLayer.pyc", line 388, in generate
    File "/Applications/", line 149, in generateFont
    File "/Applications/", line 379, in compile
    fontTools.ttLib.TTLibError: 'hmtx' table can't contain negative advance widths

    Installing Jakob Modern Regular failed
    The file does not exist at the specified URL.

  • 👋

    is the issue solved?
    did you check if you have any glyph with a negative width?

Log in to reply