Some characters not showing in space center after copy pasting



  • I am copy pasting glyphs from one font to another font.
    If they are not in the default character set (e.g. lozenge, radical or ff) they are not shown in the space center of the font they are pasted to.
    Upon closing and reopening they are there but i am sure there is a better solution?

    RoboFont 1.2 on 10.6.8


  • admin

    I cannot reproduce this issue according your description.

    By "not default" you mean, they don't have a unicode value, or they aren't presented as a template glyph?
    Do you have to close the Space Center? or the UFO document?

    Upon closing and reopening they are there but i am sure there is a better solution?

    yeah, this is idd not standard behavior :)

    thanks



  • sorry for the confusing post.

    i have a font with eg the glyph radical. I copy it from the font collection and do File –> New font. Then with no glyph selected in the new font I press paste. I can see the radical in the font collection. I select it and open a space center window. The radical is shown in the "input bar" but not in the actual window. Also in the metrics i can see the radical but no values for width, left and right margin.

    if i close the font and then reopen it everything is fine.

    Sorry again and thanks for the quick reply.


  • admin

    is the radical glyph already defined by a template glyph?

    if so it creates a radical.copy_1 glyph and pasted the drawings in there (only if you don't have a selection in the font collection)
    this implicates that the unicode value is changed and in Space Center will find your pasted glyph.

    hope this makes sense



  • The new font i am copying the radical to just has the default "Latin-1" character set. So there is no template for the radical. When i paste it (from the font that has the radical) it just adds it as a new glyph with the name radical (no .copy_1 suffix). In the inspector i see the unicode value, width and margins. Just in the space center it does not show the glyph.
    Even more surprising. I just copied the radical a second time to the new font so it adds the radical.copy_1 glyph. If i select the radical and the radical.copy_1 and open the space center it shows the radical.copy_1 but not the first version.

    is there a way to post screen shots?

    thanks


  • admin

    thanks, was able to reproduce it, will be fixed in the next update :)