Template Preview Font missing characters



  • Many characters are not showing up in the glyph templates, even though they exist in the "Template glyphs preview font" that I set in the preferences. I made sure that all characters have a unicode value, regenerated the font with a different name, but they're still not showing up.

    Is there a preferred way for setting unicode? Does it only recognize certain characters for the template preview?

    Thanks so much for your help, Frederik! You've made the transition much easier than I thought it would be.

    J


  • admin

    The template glyphs have no unicode so they will get the generic template glyph drawing.

    You can add unicodes to template glyphs by <glyphName>|<unicode>
    see http://doc.robofont.com/documentation/workspace/font-collection/adding-and-deleting-glyphs/



  • Thanks Frederik.

    I added the | syntax to the "Default Charset" for new fonts, but it didn't help. And if I "Add Glyphs" then the glyph cells turn white with no preview.
    I'd like to be able to have template glyphs for all the characters, as a visual way of keeping track of what I still have to draw.



  • Nevermind, I restarted and it seems to work!


  • admin

    As mentions in red at the bottom of the preferences if you change the template font: Template glyphs preview font will be applied after a restart.


Log in to reply