Exporting font issue (Version 1.4 (built 1301142150) - MacOsX 10.8.3)



  • Dear Robofont forum,
    I had a problem trying to export some fonts (I tried every file format).

    If I try to export it "manually", from the GUI, the progress bars appear, but no file is generated in the target folder.
    Instead, if I try to do it from the code editor, Robofont prints this message:

    "Traceback (most recent call last):
      File "lib/fontObjects/doodleFontCompiler/baseCompiler.pyc", line 273, in compile
      File "ufo2fdk/makeotfParts.pyc", line 63, in compile
      File "ufo2fdk/makeotfParts.pyc", line 78, in setupFile_outlineSource
      File "ufo2fdk/outlineOTF.pyc", line 76, in compile
      File "ufo2fdk/outlineOTF.pyc", line 547, in setupTable_CFF
      File "ufo2fdk/fontInfoData.pyc", line 175, in normalizeNameForPostscript
    TypeError: must be unicode, not str"
    

    You can find at this link a sample of the typeface:
    https://dl.dropbox.com/u/5730475/ScrambledMono_Emma.ufo.zip

    Any idea?

    Best,
    Roberto Arista



  • Hey Roberto,

    The problem seems to relate to your font family name. It exported fine for me after I deleted " Emma" from the end...

    I can't remember the naming restrictions, but I suspect the problem relates to the fact that you've used two spaces in the name. I also seem to remember that the full name can't exceed 19 or 21 characters...

    Maybe someone can clarify?

    Best,
    Dan


  • admin

    Your font family name has an soft enter char at the end.

    good luck



  • Thanks, now it works.
    I suggest to insert a tooltip showing the allowed char in the fields.

    Best,
    Roberto