SOLVED Issue with extensions on RoboFont 3

  • Hi all,

    I'm having trouble with extensions on RoboFont 3 running on MacOS 10.13.3. When I install them they work fine during that run of the app and I can use them alright. But after closing RoboFont and opening it again no extensions show up in the menu and they just can't be used at all.

    If I go to Preferences/Extensions I can see them listed there and I can also see the files in ~/Library/Application Support/RoboFont/plugins/. It happens with all the extensions I tried, including Mechanic, and also including extensions installed through Mechanic.

    Another weird thing that happens is that when I restart the app it looks as if it were starting for the first time, showing me the Purchase RoboFont... option. When I click on license my license shows up properly, and Purchase RoboFont... dissapears.

    I've tried re installing RoboFont from scratch 4 or 5 times, restarting my computer and the app multiple times between installing extensions, but nothing seems to work. Here are the Console messages after starting RoboFont, in case they could be of use to debug this:

    default	23:31:44.471908 +0000	launchservicesd	CHECKIN:0x0-0x77077 3957 com.typemytype.robofont3
    default	23:31:44.720176 +0000	kernel	AGC:: [RoboFont pid:3957 mux-aware] starting, non-mux-aware app count 0 WS-ready 1 switch-state 0 IG FBs 1 EG FBs 0:0 power-state 6 3D idle HDA idle
    error	23:31:44.788254 +0000	RoboFont	        AEGetDescData of non-desc type 'reco' not a good idea
    default	23:31:44.836832 +0000	RoboFont	data parameter is nil
    default	23:31:44.837133 +0000	RoboFont	        OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(spec,phac handler=0x7fff52b7bca2 isSys=YES) err=0/noErr
    error	23:31:44.837905 +0000	RoboFont	        AEGetDescData of non-desc type 'reco' not a good idea
    default	23:31:54.480329 +0000	RoboFont	LSExceptions shared instance invalidated for timeout.

    Has anyone experienced anything like this? Any help would be appreciated.


  • all issues related to extensions in RF3 were solved with RF3.1 & Mechanic 2.

    if you still have any problem, please start a new thread. thanks!

  • Hi all,

    I ran into similar problems recently.
    Is there any follow up on this problem?


  • admin

    The bug is being resolved in the last beta...
    It had todo with RoboFont 3 looking for data from RoboFont 1 which does not exists on a fresh OS...

  • Hi All,

    I just moved into a new computer and I'm having the exactly same issue. the mechanic and the other extensions just disappear, so every time I have to reinstall the mechanic and every single extension.

    @josesole did you already find a solution for this?


  • admin

    Are you running the app from the .dmg file?

    could you send me the robofont-3-py3.log file, (off list at all traceback inside RoboFont are store there.

    the traceback in does not ring a bell for me...

    RoboFont has its own python version embedded.

  • Reporting back. Getting rid of python 3 from brew did not help. I still get the same issue as reported before. I hope at some point we manage to figure out what is going on. Thanks for the support until now.


  • Thank you for your answer, Gustavo. I have tried installing extensions manually pulling them from github. They install well and work on the RF3 session when they are installed, same as installing Mechanic and installing other extensions through Mechanic. But once I close RF3 and then open it again any and all extensions dissapear and I seem to go back to zero again.

    I can make it work by installing extensions every time I need them on every new session, or I can try to keep RF3 open so they don't disappear when I close the application. But I imagine that's not the expected way this should work and it can be a bit cumbersome.

    Perhaps it could be because I have a custom Python installation for other work I do on my computer? I maintain that installation through Brew. I will try uninstalling that python and see what happens. I remember it causing plenty of issues when I was trying to use PageBot a while ago. Will report back.

    Thanks for taking the time to read through and for your suggestions.


  • hello José,

    I cannot reproduce the problem you report, and I have no idea what could be causing it. let’s wait and hope that @frederik has a clue.

    there is, however, another issue with Mechanic and RF3 at the moment (see the discussion here); Frederik is looking into it.

    in the meantime, you can still install extensions manually: just download the code from GitHub, and double-click the .roboFontExtension file.

  • Hello again,

    I wanted to wait a bit longer to see if anyone else reported a bug like this and to be able to ask the people I know use RoboFont to check if everything was fine for them. Based these two things and the response I've gotten, it seems I am the only one with this issue. Is there any way I could approach this issue to debug it and find a solution?

    Having to install extensions every time I want to use one after every new instance of the app is opened is not particularly great nor useable. And of course not being able to use extensions seamlessly means that, for me, the app is not working as expected.

    Does anyone have any suggestions? Is there something obvious (or non-obvious) I am missing? Is there anything I could look into that would give any clues about what is happening here?

    I really would appreciate any feedback, especially if it helps move things forward regarding this bug.

    José Solé

Log in to reply