SOLVED Pop-up every minute asking to update font

  • Note: This issue is not specific to RF3.

    While drawing, this pop-up regularly comes up and asks me to update my font. If I hit reject, everything is okay, but it comes back a minute or so later. If I hit update, it starts deleting the glyphs I just worked on, rendering my progress gone.

    I originally thought this problem occurred because of copy/paste of vector graphics from Illustrator, but I'm now suspecting it has to do with the fact that at any given moment I'm working on a server or Dropbox. Happens while using both.

    Is there a way to stop this pop-up from happening? It seems the server or Dropbox is pushing outdated edits to the font in the same way something like MetricsMachine would.

    0_1521035688677_Screen Shot 2018-03-14 at 9.45.54 AM.png

    0_1521035701243_Screen Shot 2018-03-14 at 9.46.02 AM.png

    If I hit Update on the dialog above, /K /L /M /N get deleted.

    Thanks in advance,

  • after you run the script, you'll need to close and reopen the font for the change to take effect. (I've just tested it again in RF3, works fine)

    another solution would be not working directly on a server or DropBox folder, if possible. you could ‘check out’ the font to another place, edit, and then check it back into the server. (or use a version control system like Git, which works just like that; see this tutorial in the new docs.)

  • Ran the script, and the pop-ups persisted :(

    Specific to RF3 update: some of the pop-ups now have been layer-related. And if I click update, it hangs.


  • Thanks for directing me to that resource, @gferreira . I'll try it out!

  • hello Ryan,

    this may be useful: Working of a remote file server: troubles & fixes

    you can disable automatic checking for external changes:

    from import setDefault
    setDefault("enableExternalFileCheck", False)

    …and enable it again later.

    hope it helps!