SOLVED Crash when creating new and opening existing file.

  • It started with Robofont crashing when I tried to open an existing file. This also happened when trying to create a new file.

    I've tried the following:

    • restarting computer
    • reinstalling OS X High Sierra
    • deleting all files / scripts / .py / etc associated with robofont and emptying the trash
    • reinstalling robofont 1.8.4

    So far, it still crashes when opening or creating a file.
    I'm on a MacBook Pro 2015 / High Sierra.

    Is there something else I can do to prevent this crash and get a file open?

  • the problem was indeed in the oneToThree extension (now renamed to 1To3).

    please uninstall the extension, and install the latest version. things should work fine again.

  • @zackrobbins I came across the same problem, we’re looking into it.

    RF1 works fine in Safe Mode, with no extensions installed. (to run RoboFont in Safe Mode, click and hold Shift while you launch the app.) can you please give it a try and confirm it works for you?

    we’re now trying to figure out which extension is causing the problem. the main suspect is oneToThree – do you have it installed? if not, what other extensions do you have installed?

    thanks for you feedback!

  • I'm actually still on 1.8.4 (I've been using a student license for
    several months and haven't updated to 3 yet). Should I go back and install 1.2 and "Check for Updates" within Robofont?

  • admin

    There is an issue when you didnt have RoboFont 1 installed before...

    There is a release planned next week.
    To resolve this issue directly please download RoboFont 1 first, launch it, and then start RoboFont 3

    sorry of the inconvenience but enjoy!