SOLVED OpenType features not working

  • @gferreira said in OpenType features not working:

    it’s hard to know what’s going on without more information or data to look into…

    • how are you generating and installing the font?

    I am testing it through 'Test Install'. The same files were working perfectly in RF1, UFO2 format

    • are there any errors in the console when you generate the font?

    Please see the attached report.

    • are you sure the generated font contains the features? (you can use ttx or Wakamai Foundue to see what’s inside an OpenType font)

    The features are working fine in 'Feature Preview' and I noticed the characters which has Unicode assigned like 'ff', 'fi' etc. are working but the ones without are not working.

    • if the font does contain the features: do they work elsewhere? (for example in TextEdit or in the browser)

    No,! it is not working anywhere.


  • hi @naorem, thanks for the additional info.

    it’s weird that the features work in Feature Preview, but not elsewhere.

    it seems that the features are not being generated with the test installed font (?). to check if this is the case, you can generate a fresh font with File > Generate Font, and use one of the tools mentioned above to see if the features are really included in the OTF.

    also, feel free to send me the UFO via email, and I will have a look.

  • @gferreira It seems the 'test install' and 'generate font' is not including the features. I tried both and the features are not included. Like I mentioned above that the 'Feature Preview' extension is showing the features and I didn't have this issue in RF1. maybe a good idea if you could look at the UFO and .feature file. Could I have you email please. Thanks

  • @gferreira I found a solution! If the features are included in the Feature window inside RoboFont, then it works fine. But if you call the feature from an external .fea file then it doesn't work. Do you think it's a bug?

  • @naorem glad to hear that you’ve found a workaround!

    linking to external .fea files should work fine though… I’m still curious to know why it was not working before.

    if the path to the linked .fea file is wrong, the features will not be included, and a message will appear in the Output Window:

    UserWarning: Found non existing included feature file (example.fea). This will be ignored

    are there any accented characters in the folders which contain the files? I’ve seen this create problems in the past.

    if you still wish to send me the files, my email is

  • admin

    be sure you have either a full path in the include, starting with a / (slash) or a relative path toward the ufo file.

  • @frederik the strange thing is that all the features are showing up in 'Feature Preview' extension. But not working while generating or test installing the font. The path I used to call the .fea file is include(filename.fea); which was working perfectly in RF1, UFO2. But it seems to work if I include the features in RF3 itself.

  • admin

    the include(myExternal.fea) in the features should point to a relative fea file next to the ufo file.

    Could you send over the ufo or a dummy ufo with the same issue?

  • @frederik thank you, I will mail you a UFO3 file along with the feature file

  • @frederik I have mailed you a sample UFO file with the feature issue. Hope you have received it.