Dashed-line alignment guide comes from cursor, not nearest selected object



  • TLDR: Can the dashed crosshair alignment guides always snap to the point in the selection that’s nearest the mouse position, not the mouse position itself?

    Often when looking at the dashed line that appears on mouseDown, I'm considering how that nearby point will horizontally or vertically align with others. The alignment guide’s origin currently seems to snap to the nearest point if it’s a selection of a single point. But when selecting an anchor or multiple points, it snaps to the mouse position, not the anchor position or nearby point coordinates respectively. The thresholded clickable area around these objects makes a lot of sense, but maybe the dashed line should relate more to the object pos than the mouse pos. Please see below (cursor not pictured because it isn't captured in screenshots, but in the last two it's in the dashed crosshairs.).

    One point in selection 👍:
    pt_alignment_guide_2.png

    Two points in selection:
    pt_alignment_guide.png

    One anchor in selection (also btw I think the coordinate position may be off):
    pt_alignment_guide_3.png

    RF Version 3.2 (build 1901211134)

    TIA,
    Ryan



  • May also be nice to have them responsive to scale tool as well:

    scale_tool.png


  • admin

    hello @ryan,

    the crosshair cursor is always at the mouse position. I can reproduce your last two screenshots only by dragging a selection from a segment (instead of a point).

    I agree the current crosshair position in this case is not very useful for aligning. should it be positioned on the closest point, or at the contour bounds? (trying to imagine how it would work, I think the second would be more useful)

    aligning the crosshair cursor to the scale box is a nice idea!

    ps. anchor coordinate positions are fixed in RF3.3b ;)



  • Hi @gferreira, thanks for your reply! Just checked again and it looks like there’s only one case where the crosshair is not aligned to mouse position. Can you reproduce it if you have everything deselected, and click near a point, and hold? Or rather than not being aligned to mouse position, it seems to be snapping to the grid, whereas it doesn't seem to otherwise.

    Note: If the point was previously selected before click & hold, the crosshairs don't seem to align to the grid. I could be wrong; just going off observation here.

    It may just be any quick change to consistently set the crosshairs to snap to the unit set in Preferences. Probably more nuanced than that, I don't know. I suppose it depends on what value you have set for point click distance sensitivity.

    Saw that fix of the anchor coordinates in the update right after I posted. Thanks!


  • admin

    hello @ryan, thanks for explaining.

    the cross-hair position is always the mouse position, changing the grid shouldn’t have any influence on it (that’s what the code says, as far as I can tell). wondering what else could be going on on your side…

    thinking about the alignment problem: how about using a guideline?

    I’ll create an issue for “showing crosshair cursor at selection bounds OR nearest point instead of mouse click”, let’s see what @frederik says ;)



  • Hi, @gferreira I got around to making a short video that hopefully illustrates what I'm talking about. Would be awesome if it always behaves as it does on the initial click.


  • admin

    this should be fixed in next beta or release version!

    thanks for reporting



  • Awesome, thanks guys!