SOLVED Kerning offset overflow



  • Hi there. I was wondering if someone might know how to address this error (aside from having less kerning):

    makeotfexe [FATAL] <Font> In feature 'kern' positioning rules cause an offset overflow (0x1256a) to a lookup subtable
    

    In my initial investigation it seems like the useExtension tag can be added to force the AFDKO to use offsets bigger than 64K. I’m not sure where this might be inserted though. I recall reading somewhere that there is a temporary file that Robofont passes to the AFDKO that can be modified?

    Any pointers are greatly appreciated!



  • @benkiel has a great lecture from Robothon09 on this. This might solve your problem! 🤷‍♂️



  • Hey mate,

    I vaguely remember this during Blanco. I assume you're just using MM and saving using the auto generated kerning feature.

    Have you tried exporting the kerning from metrics machine as a separate kerning file and including that in the features?

    D



  • @connor Cheers Connor. I’ll check it out!



  • @FosterType Hey Dave. I haven’t tried that. Nice tip, I’ll give it a go. Cheers.



  • Old topic but still, I had the issue too. So here is the solution : MM provide a subtable option for writing kerning into fonts. This disable the overflow issue when generating fonts.



  • Thanks Arnaud! To add to this, I had some difficulty finding where in MM to actually do this, so...

    I found the option under "Batch Export" in the MM menu. I simply exported it into the font (features), and now makeOTF works to generate fonts directly!


Log in to reply