Contours don’t export into a font



  • Quick newbie question: what's the most common reason for contours not exporting from a .ufo to a font during generation? It's not a layer thing: other contours from the layer in question do export.


  • admin

    example?

    open contours, contours that are removed by a remove overlap...


  • admin

    correction: open contours get closed during remove overlap while generating



  • I think I've found the problem, though I don't know yet how to fix it. Here's the glyph with the paths in the relevant layer:

    Screen Shot 2019-11-27 at 6.59.22 AM.png

    and here's the inspector window:

    Screen Shot 2019-11-27 at 6.59.46 AM.png

    I've highlighted what I think is wrong: a 'move' instead of 'line' in the path/contour that's not exporting. But then, you say that RF should be closing the path when it exports …



  • Anyway, selecting the offending point and closing the open contour fixed the export issue, so I'm marking this 'solved'. But I am curious as to how the contour was open in the first place—it doesn't seem to have happened in any other glyph—and why RF didn't just close it itself when exporting.


Log in to reply