Running 1.8 beside 3.3



  • I am making the transition from 1.8 to 3.3 but still have 1.8 in operation until a project started there is completed (soon). Is it possible to run these two versions together? I get traceback errors when trying to update extensions in 3.3 via Mechanic2 which I believe are related to 1.8 utilising the 1to3 extension. This seems to be confusing 3.3 and not allowing updates to take place...

    Below is a snippet of the output when attempting to update:

    Installing '1To3' report:
      Traceback (most recent call last):
          File "main.py", line 9, in <module>
          File "/Users/joesquared/Library/Application Support/RoboFont/plugins/1To3.roboFontExt/lib/RF3.py", line 12, in <module>
        ModuleNotFoundError: No module named 'ufoLib'
    
    Installing 'Add Overlap' report:
      Traceback (most recent call last):
          File "AddOverlap.py", line 3, in <module>
        ModuleNotFoundError: No module named 'ufoLib'
    

    Am I better off waiting to make the jump until I can remove 1.8, or am I missing something simple?

    Thanks!



  • As for AddOverlap, try deinstalling it and then installing a fresh one from GitHub. Works for me. Supports 3.3 and looks to have a RF1 contingency built-in:

    try: # RF3
        from fontTools.pens.pointPen import AbstractPointPen
    except: # RF1
        from robofab.pens.pointPen import AbstractPointPen
    


  • Thanks for the suggestion, Ryan. I have tried to uninstall the extensions that won’t update but, that is also failing...



  • I solved this by trashing the faulty ext’s from /applicationSupport/Robofont/plugins then deinstalling in Mechanic 2 followed by installing fresh.


  • admin

    hello @JustJoeDesign,

    you can configure different folders for extensions in each version of RF, so you can keep your 1.8 setup and start fresh on 3.3 – see this thread for more info.

    hope this helps! cheers



  • Hi @gferreira,

    That is good to know! Thanks for sharing.


Log in to reply