Can't test install or generate



  • On 'Test Install' I get a dialog box that says 'Error installing "MyFontName" See Output window for compiling errors!'

    However, the output window (the one under the python toolbar) shows nothing. Neither does the console window.

    When trying to 'Generate Font' it goes through the motions with no errors, but an otf file does not show up in the specified folder.

    I've tried with new and blank font files, as well as reinstalling RoboFont. No luck yet.

    When using the demo version a few months ago, the test install/generate did work. This is the first I've tried to test install after purchasing the full version.

    The one possible area that may help shed some light... I've been doing some work in ruby/rails and kept getting a terminal warning 'insecure writable dir /bin/FDK'. To get around that I had to 'chmod go-w' on the directory. Could that have messed something up with RoboFont talking to FDK?

    I'm just not sure where to look to fix this issue. Thanks in advance for any help.



  • Ok, I think I've gotten it to work.

    If I deselect 'Use embedded FDK for font generation' in the preferences, the fonts now generate.

    It would still be helpful to know what the source of the problem is, to avoid potential issues with future updates to FDK or RoboFont.


  • admin

    He Travis

    this is a know issue, once generating fails the print outs send to the output window gets lost....

    this will be solved in the next version.

    the best workaround is to use a local install of FDK


  • admin

    is autohint enabled for test install? (see preferences)

    if so see topic: psBlueValues required when generating otf with autohinting



  • Thanks for the info Frederik! I did not have blue values specified, so that was probably it.



  • Hi Frederik,
    I have the same problem: When generating the font, there is no font generated. When test installing, I get following error:

    Error installing: See output window for compiling errors
    

    The output window is empty.

    I have specified blue values . For Test install options, I have tried with checked and unchecked Auto Hint.


  • admin

    do you have any features written?
    (just thinking about places where things can go wrong)

    (its a bug that there are no print outs in the output window, this will be solved in the next version)



  • No, I don't have any features written. Until yesterday test installing worked completly fine. Now, I just amended the design of a letter and test installing doesn't work anymore. I have as well tried to test install previous versions of the font (that I have been installed sucessfully), but it wouldn't test install them anymore.

    Thanks a lot for your help!