RF 1.8 Test Install hmtx error



  • Hi everyone,

    I'm running RF version 1.8.3b (built 1702022141) under 10.13.6 (17G12034). After generating a few instances from Superpolator Version 170206_0936_developer_ (developer), some of them won't test install. Looking at the output window, the bottom line says: TTLibError: 'hmtx' table can't contain negative advance widths.
    Some context, I'm working on an Italic font, interpolating slightly bolder weights for the Book and Bold masters. The Bold Italic ones are causing troubles.

    Thank you for your help!

    Mathieu

    ps: I know I'm a bit being version wise. In the process of finishing a first type family, I’m sticking to this environment which works smoothly - until today - with the handful of scripts & extensions that I’m using.


  • admin

    old tools!!

    you have glyphs with negative spacing and that is not possible in a binary font... however this is valid in a UFO

    # find all negative spaced glyphs
    font = CurrentFont()
    
    for glyph in font:
        if glyph.width < 0:
            print(glyph.name)
    

    good luck!!



  • Thank you Frederik, your script help me find the culprits easily. After fixing those 3 glyphs in the master, the interpolated instances generate successfully. Solved!