SOLVED Prepolator and MetricsMachine are not listed in Mechanic 2.0

  • Prepolator and MetricsMachine do not show up in Mechanic 2.0.
    How will I know when there's an update?


  • hello @paulvanderlaan,

    it turns out the problem is not related to Mechanic2 at all, but to old macOS 10.10 which gets confused when multiple certificates are attached to a domain – this causes Safari and macOS to think that the certificate is invalid (it works in Firefox and Chrome though).

    the good news is that you can use an older version of Mechanic (zip link) which is a bit slower but can display extensions from the Extension Store on macOS 10.10.

    thanks @frederik for looking into it!

  • @paulvanderlaan thanks for checking. I’m a bit out of my depth at this point, hopefully @frederik or @verbosus can give us a hand… (to be continued)

  • I just tried to change it to http but it does not get accepted. Somehow it automatically changes it into https and throws an error. :/

    Strangely the url to is also https and that one appears to work correct.
    I can see and update extensions from that source.


  • thanks for the info – issue created here.

    I think the problem is related to SSL certificates and macOS 10.10. does it work if you use http instead of https in the extension stream URL?

  • OS X 10.10.5 with similar misbehaviour in both RF3.3 and RF3.5b-2005131711.
    (RF3.4 does not work on 10.10)

  • thanks @paulvanderlaan, this might give a few clues about what’s going on.

    the json stream is alive and well, as far as I can test.

    I’ll create an issue in the Mechanic 2 repository…

    what is your version of macOS? does this happen on RF 3.4 too?

  • I found something in robofont-3-py3.log

    20/05/2020 14:16:04 >    ERROR > Mechanic >> Cannot read url ''
    20/05/2020 14:16:04 >    ERROR > Mechanic >> Error 'Error Domain=NSURLErrorDomain Code=-1200 "The operation couldn’t be completed. (NSURLErrorDomain error -1200.)" UserInfo=0x6000001a2760 {_kCFStreamErrorDomainKey=3, _kCFStreamErrorCodeKey=-9824, NSUnderlyingError=0x600000244080 "The operation couldn’t be completed. (kCFErrorDomainCFNetwork error -1200.)", NSErrorPeerCertificateChainKey=(
                                              >> ), NSErrorFailingURLKey=, NSErrorFailingURLStringKey=, NSErrorClientCertificateStateKey=0}'

  • The same json files are defined here.

    Indeed other paid extensions such as Skateboard and FindAndReplace are not listed as well.


  • hi @paulvanderlaan,

    if none of the extensions from the Extension Store are showing up in the Mechanic2 list (also Skateboard and FindAndReplace), it probably means that the store’s json file was not loaded.

    can you please check it the store’s json URL is included in the extension stream settings?


  • Hmmm. Nothing shown here. :/

    I bought both extensions last week, downloaded them from the links that I got, and then double clicked to install them.



    RoboFont 3.3

  • hello @paulvanderlaan,

    extensions from the Extension Store appear at the end of the list. you can also search by extension name, developer name, etc.

    see also Updating extensions