SOLVED Variable Font in InDesign: strange behaviour of slider



  • Hello,
    It is not connected directly with RoboFont app, but maybe some of you will know how to help me with my issue.

    I have this typeface, that has separate variable font files for Romans and Italics. Both fonts have corresponding named instances and one axis (weight axis).
    I installed this font in my adobe font folder to test it in different adobe apps.
    Illustrator works smoothly.
    But in InDesign I have a problem.

    This is what happens:
    If I select, for example, "Bold" from the style dropdown and I want to see how the letter shape behaves by dragging the axis slider my font jumps immediately to the italic style.

    Does anyone know what to do with this?

    I tried to set STAT table, I renamed default masters from the scratch, I recreated design space files several times. I exported font with makeotf and fontmake separately. With different apps. I still have no clue how does it work for example in SourceSans. I believe that I omitted some important stuff in the spec.

    Here I'm attaching source files and ttf files of my test font that behaves the same. There is also a small video illustrating what is happening.

    I lost all my hope,

    Thanks in advance



  • I solved the issue with help of some people. Anyways, here is a link to the discussion on typedrawers that describes this issue and the solution.

    https://typedrawers.com/discussion/3750/variabe-font-issue-in-indesign-2020#latest


  • admin

    thanks for the link!