SOLVED Autohint not working

  • Hello,

    I upgraded to Monterey OS and Robofont 4. I have issues with autohint which does not seem to operate while using Batch.

    None of the glyphs are hinted,

            makeotfexe [WARNING] unhinted <A>
            makeotfexe [WARNING] unhinted <B>
            makeotfexe [WARNING] unhinted <C>
            makeotfexe [WARNING] unhinted <D>
            makeotfexe [WARNING] unhinted <E>

    And I have this message in the report:

             autohint Report
            Traceback (most recent call last):
              File "/Applications/", line 283, in _executeCommand
              File "/Applications/", line 333, in embedded_psautohint
              File "/Applications/", line 891, in hintFiles
              File "/Applications/", line 821, in hint_regular_fonts
              File "/Applications/", line 476, in get_fontinfo_list
              File "/Applications/", line 514, in get_fontinfo_list_withFontInfo
              File "/Applications/", line 1168, in getfdInfo
              File "/Applications/", line 1087, in getFontInfo
              File "/Applications/", line 1015, in flattenBlends
    exError: list index out of range

    I tried with different fonts, I have the same issues.
    Do I have to install something to fix this problem ?


  • admin

  • Batch generates fonts in two separate moments, first without autohint, then it autohints the font. The console log comes from the first part of the process :)

    So, the non-issue is solved, Batch autohints your fonts if required!

  • sure, i've sent it per email.

  • admin

    mmm, could you send me the ufo file?

  • @frederik They are already set in font info

  • admin

    I guess from a quick look: you will need to feed it some blueValues...

Log in to reply