Error when saving any ufo



  • This is the err

    The document “widths.ufo” could not be saved. The file isn’t in the correct format.

    Traceback (most recent call last):
      File "lib/doodleDocument.pyc", line 269, in writeSafelyToURL_ofType_forSaveOperation_error_
      File "lib/fontObjects/doodleFont.pyc", line 554, in save
      File "/Applications/RoboFont.app/Contents/Resources/lib/python2.7/robofab/glifLib.py", line 214, in writeGlyph
      File "/Applications/RoboFont.app/Contents/Resources/lib/python2.7/robofab/glifLib.py", line 349, in writeGlyphToString
      File "build/bdist.macosx-10.10-intel/egg/xmlWriter.py", line 4, in <module>
    ImportError: No module named py23
    

  • admin

    This is been solved already in the beta of the upcoming 1.7 release

    I would not recommend to fiddle around in the zipped site packages (fe: the code signing will be broken)



  • If you have a quick fix it would be much appreciated.

    I'm not sure if this helps but this started happening after installing ufo2otf.



  • Font-Tools was reinstalled and they share "stuff"... I have a feeling this is caused by installing it via the setup file in a projects subdirectory... but I'm not sure how to reverse this process.

    I also installed ADFKO, RoboFab and ufo2fdk


  • admin

    Hi

    What concerns me a little bit is the different path to the xmlWriter, why it using an other one then the one embedded in RoboFont?
    Did you install something specific? or changed some files in the package?

    FontTools is embedded in RoboFont and I would not advice to use an other version, as many things changed between versions of FontTools...
    The same goes for roboFab and ufo2fdk, both packages are embedded in RoboFont.

    You can install those packages if you need them outside RoboFont but internally I would not change the content of any package.

    how did you install ufo2otf? from inside RoboFont or did you use terminal?



  • I didn't change anything in RoboFont.. and I deleted it and reinstalled it and tried using it as a device.. all giving me the same error.

    About the embedding.. that is what I thought.. which is why I was surprised it broke a part of robofont. I installed ufo2otf via terminal.

    They would have installed globally.. I think.. since I installed it/its dependencies via terminal within a separate node project. I ended up not getting that to work so I gave up and just "sudo easy_install ufo2otf"ed it.

    If there is a way to reset those changes I would be happy to do it.


  • admin

    can you send me a personal email? I guess this fixed in the upcoming release, where a newer fontTools is embedded. The xmlWriter packages has been moved around several times (not so nice) but this is resolved (see https://github.com/behdad/fonttools/issues/190)

    thanks



  • Same thing happened on my machine (10.9) when updating the FontTools in the site-packages folder. It seems some external modules are used by RoboFont when they are present, which causes some confusion in this case.

    You could either delete the FontTools module in /Library/Python/2.7/site-packages or update the RoboFont-internal FontTools module (/Applications/RoboFont.app/Contents/Resources/lib/python2.7/fontTools) to the same version as in site-packages.


  • admin

    This is been solved already in the beta of the upcoming 1.7 release

    I would not recommend to fiddle around in the zipped site packages (fe: the code signing will be broken)


Log in to reply