SOLVED testInstall error

  • i just tried to testInstall different ufos (converted and saved as ufo3) in RoboFont3 and I am getting the following error message:

    makeotf Report
    Traceback (most recent call last):
      File "/Applications/", line 279, in _executeCommand
      File "/Applications/", line 317, in embedded_makeotf
      File "", line 1320, in getOptions
      File "", line 1334, in checkInputFile
      File "", line 1807, in convertFontIfNeeded
    TypeError: a bytes-like object is required, not 'str'
    Installing xxxx-180323 Regular failed
    The file does not exist at the specified URL.

    thanks j

  • great news,
    it would be nice to give the beta version a test,
    so yes please,
    thanks a lot!

  • admin

    Those issues should be fixed in the beta and the upcomming RoboFont3.1 release

    I can send you a beta if you like to test, let me know


  • on my 10.10.2 machine I get the above traceback. no other errormessage. also in the user library log there is no further message. I also tested this with extensions disabled, but the errormessage persists.

    For a further test I installed robofont on a friends machine running 10.10.5. I used IBM plex from github and running testinstall gives me the following traceback.

    Failed to generate the font for test install
    Traceback (most recent call last):
     File "lib/doodleDelegate.pyc", line 176, in testInstallFont_forWindow_
     File "lib/fontObjects/doodleFont.pyc", line 256, in generate
     File "lib/fontObjects/doodleLayer.pyc", line 296, in generate
     File "/Applications/", line 146, in generateFont
     File "/Applications/", line 333, in compile
    RuntimeError: dictionary changed size during iteration
    Installing IBM Plex Mono Bold failed
    The file does not exist at the specified URL.

  • admin

    on your 10.10 machine you get the traceback you posted earlier?

    any other tracebacks? in both the output window or in the robofont-3-py3.log file in <user>/Library/Application Support/RoboFont



  • hi frederik, thanks for your reply!
    I actually do want to use RoboFont’s FDK! I only tried with the not embedded one to narrow down the error.
    I just tried with my other computer running OS 10.13.1 and there the testInstall() works. But on my old – but preferred – machine with 10.10.2 it does not work. :(

    any idea of a possible workaround?

  • admin

    Oh, thanks for the ufo, it works with both the embedded FDK as with my local FDK install.

    I would advice to update FDK... there are newer versions around :)

    Is there a specific reason why you want to that FDK version?
    or why do you prefer not to use the embedded FDK?

    good luck

  • I did some more testing with a new font / ufo and the error shows up as well.
    If I uncheck the ‘Use embedded FDK for font generation’ the test install works. makeoft in terminal says: v2.0.94 May 23 2016
    Will send the ufo by email. thanks!

  • admin

    that seems like a py3 bug... in makeotf

    will have a look next week.

    Could you send me offlist the ufo data? if possible