Remote Scripting



  • Hey there,

    I think I found a bug in 3.2 with the remote scripting panel, though this could be just a mistake on my end. My remote scripting randomly stopped working so I tried to re-install the shell command. Though I keep getting a -bash: robofont: command not found in the command line despite restarting my computer, roboFont, and iTerm — and every time that I reopen robofont the install shell command is de-installed.

    Thanks in advance,
    Connor


  • admin

    I see...


  • admin

    The command is installed in /usr/local/bin/roboFont

    Try to remove it manually, restart RF and install the command again.

    hope this helps...



  • Hey Frederik,

    Sorry for the late reply...my /usr/local/bin/roboFont folder is empty despite your instructions. Would it be possible for one to share the contents of that folder and just place them manually?

    C


  • admin

    that is not a folder but where the command is saved. If there is nothing there then the command is not installed ;).



  • Oh I'm an idiot — thank you Frederik!



  • I ran into this issue as well, setting up RoboFont on a new computer. I'm not sure exactly what caused it, because I think I tried to install the shell command previously, but got caught with something else.

    Just in case someone else comes across this, I solved it by:

    1. installing PyObjC with pip install -U pyobjc (I found out this was already installed)
    2. navigating to /usr/local/bin/
    3. deleting /usr/local/bin/roboFont
    4. installing the shell command again