Slow app activation (when scripting window(s) open?)



  • Hi; I've been noticing that RF3 is slow to activate when switching between apps using cmd+tab.

    I suspect it has something to do with the python scripting window for the following reasons:
    1: when I have a single font open, it switches fast. I have tested with 3 ufos open each with full latin character sets and it still switches fast
    2: it slows down, but bearably, if I have a single scripting window open
    3: it slows down to an unbearable amount if I open more scripting windows, the more I open, the worse it is

    BUT the problem persists if I close the scripting windows.
    Relaunching the app puts me back to square one.

    At this point confirmation that it's not only me would be good; beyond that it would be great if this could be fixed or I could be advised if there's a setting I should be using to bring back the speed I am used to in RF1.

    Thanks!
    Mojave 10.14.3
    RoboFont 3.1


  • admin

    could you already update to RoboFont 3.2? and see if the problem persists?

    are there tracebacks or console logs?

    see https://robofont.com/documentation/how-tos/submitting-bug-reports/

    thanks



  • @frederik I have just tested 3.2 and I get the same result. This video makes it clear:
    https://drive.google.com/open?id=1ybf2QQsLWk9cEckABTUlPWJTxwWbqBzr
    You see how the first few times I switch app it is immediate, but get's progressively slower the more scripting windows I add.

    There's nothing in the robofont python output, but in the OS console I seem to get something like this everytime I switch.

    27366555: RECEIVED OUT-OF-SEQUENCE NOTIFICATION: 0 vs 190, 513, <private>
    

    I do not know enough to tell you if this is relevant or not :) but it is the RoboFont process and the number 190 changes each time but the other numbers stay.

    Thanks for looking into it!


  • admin

    very strange indeed...

    I cannot reproduce this on 10.13, will try on a 10.14 later on today.